Routing

Overview

Static routing is a form of routing that occurs when a router uses a manually-configured routing entry, rather than information from dynamic routing traffic. In many cases, static routes are manually configured by a network administrator by adding entries into a routing table, though this may not always be the case. Unlike dynamic routing, static routes are fixed and do not change if the network is changed or reconfigured. Static routing and dynamic routing are not mutually exclusive. Both dynamic routing and static routing are usually used on a router to maximize routing efficiency and to provide backups in the event that dynamic routing information fails to be exchanged. Static routing can also be used in stub networks, or to provide a gateway of last resort.

Static routing may have the following uses:

  • Static routing can be used to define an exit point from a router when no other routes are available or necessary. This is called a default route.
  • Static routing can be used for small networks that require only one or two routes. This is often more efficient since a link is not being wasted by exchanging dynamic routing information.
  • Static routing is often used as a complement to dynamic routing to provide a failsafe backup in the event that a dynamic route is unavailable.
  • Static routing is often used to help transfer routing information from one routing protocol to another (routing redistribution).

Dynamic routing, also called adaptive routing, is a process where a router can forward data via a different route or given destination based on the current conditions of the communication circuits within a system. The term is most commonly associated with data networking to describe the capability of a network to ‘route around’ damage, such as loss of a node or a connection between nodes, so long as other path choices are available. Dynamic routing allows as many routes as possible to remain valid in response to the change.

Systems that do not implement dynamic routing are described as using static routing, where routes through a network are described by fixed paths. RansNet Appliances supports Dynamic Open Shortest Path First (OSPF), which is a standard dynamic routing protocol and can interoperate with 3rd-party devices as well

The RansNet Gateway Routing UI facilitates users to configure Static Route and Dynamic OSPF Route based on your topology.

NOTE

Static Route – Is a process in which we have to manually add routes in routing table.

Dynamic Route – Automatic adjust the routes according to the current state in the routing table. Dynamic routing uses protocols to discover network destinations and the routes to reach it.

Static Routing

User can access the Route UI by clicking ‘Routing’ under the dropdown menu of  tab. User can click the IP Address in the ‘Gateway/Route‘ column to edit it (Static Route Only).

Image 1 : SD-WAN Gateway Routing UI

The fields of the Static Routes List are explained below:

S/NFieldsDescription
01.Gateway/RouteList’s the Default Gateway / Destination Network IP address.
02.DestinationDisplays the type of the static route (Default Gateway / Static Route)
03. NexthopNext hop is the next gateway interface to which packets should be forwarded.
04.DistanceThe value of the routers distance (Selects the best path when there are two or more different routes to the same destination)  Administrative distance defines the reliability of a routing
05.RemarksUser’s input as caption
06.ActionDisplays the delete icon to delete the particular route.
Table 1 : The Fields of Static Routes List

New Static Route Interface

To create new static route , click on the button as in Image 1.

Image 2 : Popup Window to add Static Route

Settings of Static Route

The New/Edit Static Route UI has two Destination Options, namely ‘Default Gateway‘ and ‘Network/Netmask‘.

S/NFieldsOptionsDescription
01.Destination
Default GatewayThis option has 1 required field:
01. Default Gateway IP: The Nexthop IP address.
Network/NetmaskThis option has 2 required and 2 optional fields:
01. Route Destination: The next routing hop based on the destination IP address
02. Nexthop: Next hop is the next gateway interface to which packets should be forwarded.
03. Administrative Distance (Optional): The value of the distance of the router (Selects the best path when there are two or more different routes to the same destination)  Administrative distance defines the reliability of a routing
04. Remarks (Optional): User’s input as a caption
Table 2 : Settings of Static Route

Understand The Fundamentals

For a router (in this case CMG/HSG/HSA/UA) to forward a packet to its destination

  • First, it will check if there’s a match in its routing table for the destination IP
    • if there is no match (eg. no specific route, no default route), the packet is dropped;
    • if there is a match (eg. either through a specific route learn from static/OSPF/BGP, or at least have a default route 0.0.0.0/0), then move to the next step
  • Next, it will determine the exit interface.
    • If the nexthop is configured as an IP address, it will do a local lookup (check connected routes) to auto determine exit interface;
    • If the next nexthop is configured as an exit interface, then it’s directly determined.
  • Finally, the router must check the exit interface type and decide how to forward out the packet.
    • if the exit interface is an Ethernet/multipoint link,
      1. if the nexthop is configured as an IP address, it will do an ARP request to determine the nexthop router MAC address and “wrap” the packet into a Layer-2 frame using its exit interface MAC as the source and nexthop router MAC as the destination, and successfully forward out the frame.
      2. if the nexthop is configured as an exit interface, the router will assume the destination host is directly connected/attached to the exit interface and try to do an ARP request for the destination IP directly (instead of ARP for nexthop router IP, as in #1), then the ARP request will fail because no one will reply to the ARP request (the actual destination host is in a distant network). Therefore this will end up in reachability failure.
  • If the exit interface is an point-to-point link (eg. PPPoE or LTE), the router only expects one host/router next to it, and will always forward all packets to next router, therefore, we can configure nexthop as either IP address or exit interface. Both will work.

SUMMARY PROCEDURE

enable
configure
ip route [destination ip] nexthop [ip address/interface]

If the uplink is Ethernet/multipoint interface, we must configure IP address as nexthop, eg.

!
ip route 0.0.0.0/0 nexthop 192.168.1.1
ip route 0.0.0.0/0 nexthop eth1
!

If the uplink is point-to-point interface (PPPoE or 3g-lte0/1), we can configure either IP or exit interface as nexthop, but for simplicity we usually just use exit interface (so that we can save the trouble of having to find out the nexthop IP address), eg.

!
ip route 0.0.0.0/0 nexthop eth1
ip route 0.0.0.0/0 nexthop ppp0
ip route 0.0.0.0/0 nexthop 3g-lteX (X - LTE interface number)
!

Policy-Based Routes

See Policy-Based Routing (PBR) link

User can configure PBR in the Policy-Based Routes section of the Routing UI to configure details.

Dynamic Routing

Dynamic routing makes automatic adjustments of the routes in the routing table. Dynamic routing uses protocols to discover network destinations and the routes to reach them. RansNet Appliances supports Dynamic Open Shortest Path First (OSPF), which is a standard dynamic routing protocol and can interoperate with 3rd-party devices as well.

User can Enable Dynamic Routing (OSPF) by sliding the button from the the section head of the Routing UI to configure details.

Image 3 : SD-WAN Gateway Dynamic Routing (OSPF) UI

Settings of Dynamic Routing (OSPF)

The parameters to configure Dynamic Routing (OSPF) are explained below:

S/NFieldsDescription
01.Routing OSPFSelect the OSPF option from the list
Network: Defines a Network IP address on which OSPF runs for that Network.
Router ID: This option is used to provide a unique identity to the OSPF Router. OSPF Router ID is assigned to each router running the OSPF protocol.
02.Network ID/AreaNeed to specify the Network IP and Wild card Mask
Network ID:
Network Area:
03.Enable/Disable ParametersRedistribute BGP Routes option can be Enabled or Disabled:
If Enabled the redistributes routes learned from another routing process into OSPF.
Table 2 : Settings of Dynamic Routing

mBox supports three types of peering scenario/authentication,

– No authentication

– pre-shared clear text authentication (Type 1)

– pre-shared MD5 cryptographic passwords (Type 2)with other vendor network appliances.

!
hostname CMG1
!
interface bridge br0
 enable
 ip address 172.16.1.253/24
!
router ospf
 network 172.16.1.0/24 area 0
 redistribute connected route-map SDWAN_ADVERTISED_NET
 redistribute static route-map SDWAN_ADVERTISED_NET
!

hostname CMG2
!
interface eth0
 description "ISP1 connection"
 enable
 ip address dhcp
!
interface eth1
 enable
 ip address 10.10.10.10/24
!
ip route 2.2.2.0/24 nexthop eth1
ip route 3.3.3.3/24 nexthop eth0
!
router ospf
 network 172.16.1.0/24 area 0
 redistribute connected route-map SDWAN_ADVERTISED_NET
 redistribute static route-map SDWAN_ADVERTISED_NET
!